# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$//gm;t' <<< "9999 999 999
+91 99 99 99 9999
999.999.999
99999999
677887 78787
99 (999) 99 99
9999 999 999
+91 99 99 99 9999
999.999.999"