using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$";
string substitution = @"";
string input = @"9999 999 999
+91 99 99 99 9999
999.999.999
99999999
677887 78787
99 (999) 99 99
9999 999 999
+91 99 99 99 9999
999.999.999";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}