const regex = /^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$', 'gm')
const str = `9999 999 999
+91 99 99 99 9999
999.999.999
99999999
677887 78787
99 (999) 99 99
9999 999 999
+91 99 99 99 9999
999.999.999`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);