package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$`)
var str = `9999 999 999
+91 99 99 99 9999
999.999.999
99999999
677887 78787
99 (999) 99 99
9999 999 999
+91 99 99 99 9999
999.999.999`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}