import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$";
final String string = "9999 999 999\n"
+ "+91 99 99 99 9999\n"
+ "999.999.999\n"
+ "99999999\n"
+ "677887 78787\n"
+ "99 (999) 99 99\n"
+ "9999 999 999\n"
+ "+91 99 99 99 9999\n"
+ "999.999.999";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}