# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$"
test_str = ("9999 999 999\n"
"+91 99 99 99 9999\n"
"999.999.999\n"
"99999999\n"
"677887 78787\n"
"99 (999) 99 99\n"
"9999 999 999\n"
"+91 99 99 99 9999\n"
"999.999.999")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.