$re = '/^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$/m';
$str = '9999 999 999
+91 99 99 99 9999
999.999.999
99999999
677887 78787
99 (999) 99 99
9999 999 999
+91 99 99 99 9999
999.999.999';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;