#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$"
Local $sString = "9999 999 999" & @CRLF & _
"+91 99 99 99 9999" & @CRLF & _
"999.999.999" & @CRLF & _
"99999999" & @CRLF & _
"677887 78787" & @CRLF & _
"99 (999) 99 99" & @CRLF & _
"9999 999 999" & @CRLF & _
"+91 99 99 99 9999" & @CRLF & _
"999.999.999"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)