use strict;
my $str = '9999 999 999
+91 99 99 99 9999
999.999.999
99999999
677887 78787
99 (999) 99 99
9999 999 999
+91 99 99 99 9999
999.999.999';
my $regex = qr/^[-()+ .]?(?:[0-9]+[-()+ .]+)+[0-9]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";