use strict;
my $str = '<Operation dedupMode="normal" name="update">';
my $regex = qr/(dedupMode=")(?:normal|accept|manual|review)(")/mp;
my $subst = '\\1manual\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";