import re
regex = re.compile(r'(dedupMode=")(?:normal|accept|manual|review)(")', flags=re.MULTILINE)
test_str = "<Operation dedupMode=\"normal\" name=\"update\">"
subst = "\\1manual\\2"
result = regex.sub(subst, test_str)
if result:
print(result)