import Foundation
let pattern = #"(dedupMode=")(?:normal|accept|manual|review)(")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<Operation dedupMode="normal" name="update">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1manual\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)