// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(dedupMode=")(?:normal|accept|manual|review)(")"#).unwrap();
let string = "<Operation dedupMode=\"normal\" name=\"update\">";
let substitution = "\\1manual\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}