re = /(dedupMode=")(?:normal|accept|manual|review)(")/m
str = '<Operation dedupMode="normal" name="update">'
subst = '\\1manual\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result