# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*([^\*]+)\*/<span>$1<\/span>/gm;t' <<< "text *inner text 1* text2 *inner text 2*"