const regex = /\*([^\*]+)\*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*([^\\*]+)\\*', 'gm')
const str = `text *inner text 1* text2 *inner text 2*`;
const subst = `<span>$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);