#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\*([^\*]+)\*"
Local $sString = "text *inner text 1* text2 *inner text 2*"
Local $sSubst = "<span>$1</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)