re = /\*([^\*]+)\*/m
str = 'text *inner text 1* text2 *inner text 2*'
subst = '<span>$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result