$re = '/\*([^\*]+)\*/m';
$str = 'text *inner text 1* text2 *inner text 2*';
$subst = "<span>$1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;