import re
regex = re.compile(r"\*([^\*]+)\*", flags=re.MULTILINE)
test_str = "text *inner text 1* text2 *inner text 2*"
subst = "<span>$1</span>"
result = regex.sub(subst, test_str)
if result:
print(result)