package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\*([^\*]+)\*`)
var str = `text *inner text 1* text2 *inner text 2*`
var substitution = "<span>$1</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}