using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[pause[^]]*""(\d+)""]";
string substitution = @"<break time=""$1ms""/>";
string input = @"I am [pitch = ""high""]Rudratosh Shastri[endpitch]. what is your name ? how are you? sorry [pause =""3000""] i can not hear you ?[rate=""-70.00%""] i still can't hear you[endrate] ? [rate=""+50.00%""]why i can't hear you[endrate] ?";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}