package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[pause[^]]*"(\d+)"]`)
var str = `I am [pitch = "high"]Rudratosh Shastri[endpitch]. what is your name ? how are you? sorry [pause ="3000"] i can not hear you ?[rate="-70.00%"] i still can't hear you[endrate] ? [rate="+50.00%"]why i can't hear you[endrate] ?`
var substitution = "<break time="$1ms"/>"
fmt.Println(re.ReplaceAllString(str, substitution))
}