use strict;
my $str = 'I am [pitch = "high"]Rudratosh Shastri[endpitch]. what is your name ? how are you? sorry [pause ="3000"] i can not hear you ?[rate="-70.00%"] i still can\'t hear you[endrate] ? [rate="+50.00%"]why i can\'t hear you[endrate] ?';
my $regex = qr/\[pause[^]]*"(\d+)"]/mp;
my $subst = '<break time="$1ms"/>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";