$re = '/\[pause[^]]*"(\d+)"]/m';
$str = 'I am [pitch = "high"]Rudratosh Shastri[endpitch]. what is your name ? how are you? sorry [pause ="3000"] i can not hear you ?[rate="-70.00%"] i still can\'t hear you[endrate] ? [rate="+50.00%"]why i can\'t hear you[endrate] ?';
$subst = "<break time=\"$1ms\"/>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;