const regex = /\[pause[^]]*"(\d+)"]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[pause[^]]*"(\\d+)"]', 'gm')
const str = `I am [pitch = "high"]Rudratosh Shastri[endpitch]. what is your name ? how are you? sorry [pause ="3000"] i can not hear you ?[rate="-70.00%"] i still can't hear you[endrate] ? [rate="+50.00%"]why i can't hear you[endrate] ?`;
const subst = `<break time="$1ms"/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);