# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[pause[^]]*\"(\d+)\"]"
test_str = "I am [pitch = \"high\"]Rudratosh Shastri[endpitch]. what is your name ? how are you? sorry [pause =\"3000\"] i can not hear you ?[rate=\"-70.00%\"] i still can't hear you[endrate] ? [rate=\"+50.00%\"]why i can't hear you[endrate] ?"
subst = "<break time=\"$1ms\"/>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.