// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[pause[^]]*"(\d+)"]"#).unwrap();
let string = "I am [pitch = \"high\"]Rudratosh Shastri[endpitch]. what is your name ? how are you? sorry [pause =\"3000\"] i can not hear you ?[rate=\"-70.00%\"] i still can't hear you[endrate] ? [rate=\"+50.00%\"]why i can't hear you[endrate] ?";
let substitution = "<break time=\"$1ms\"/>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}