import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[pause[^]]*\"(\\d+)\"]";
final String string = "I am [pitch = \"high\"]Rudratosh Shastri[endpitch]. what is your name ? how are you? sorry [pause =\"3000\"] i can not hear you ?[rate=\"-70.00%\"] i still can't hear you[endrate] ? [rate=\"+50.00%\"]why i can't hear you[endrate] ?";
final String subst = "<break time=\"$1ms\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}