# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(print\(.*\))/verb_printer($1)/gm;t' <<< "def verb_printer(msg, verb):
if verb:
print(msg)
"