// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(print\(.*\))").unwrap();
let string = "def verb_printer(msg, verb):
if verb:
print(msg)
";
let substitution = "verb_printer($1)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}