const regex = /(print\(.*\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(print\\(.*\\))', 'gm')
const str = `def verb_printer(msg, verb):
if verb:
print(msg)
`;
const subst = `verb_printer($1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);