re = /(print\(.*\))/m
str = 'def verb_printer(msg, verb):
if verb:
print(msg)
'
subst = 'verb_printer($1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result