use strict;
my $str = 'def verb_printer(msg, verb):
if verb:
print(msg)
';
my $regex = qr/(print\(.*\))/mp;
my $subst = 'verb_printer($1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";