$re = '/(print\(.*\))/m';
$str = 'def verb_printer(msg, verb):
if verb:
print(msg)
';
$subst = "verb_printer($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;