package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(print\(.*\))`)
var str = `def verb_printer(msg, verb):
if verb:
print(msg)
`
var substitution = "verb_printer($1)"
fmt.Println(re.ReplaceAllString(str, substitution))
}