# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h+(\S+)$/,\1/gm;t' <<< "Some text 123 here and then 44.99
more text 789 is 33.75"