const regex = /\h+(\S+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h+(\\S+)$', 'gm')
const str = `Some text 123 here and then 44.99
more text 789 is 33.75`;
const subst = `,\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);