use strict;
my $str = 'Some text 123 here and then 44.99
more text 789 is 33.75';
my $regex = qr/\h+(\S+)$/mp;
my $subst = ',\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";