// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\h+(\S+)$").unwrap();
let string = "Some text 123 here and then 44.99
more text 789 is 33.75";
let substitution = ",\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}