#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\h+(\S+)$"
Local $sString = "Some text 123 here and then 44.99" & @CRLF & _
"more text 789 is 33.75"
Local $sSubst = ",\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)