using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h+(\S+)$";
string substitution = @",\1";
string input = @"Some text 123 here and then 44.99
more text 789 is 33.75";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}