import Foundation
let pattern = #"\h+(\S+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Some text 123 here and then 44.99
more text 789 is 33.75
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #",\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)