re = /\h+(\S+)$/m
str = 'Some text 123 here and then 44.99
more text 789 is 33.75'
subst = ',\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result