package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\h+(\S+)$`)
var str = `Some text 123 here and then 44.99
more text 789 is 33.75`
var substitution = ",\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}