using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ (\w*?): ((Number|String|Object|Array),?\n)";
string substitution = @" $1: {\n type: $3,\n required: true\n },\n\n";
string input = @"
props: {
book: Object,
progress: Object,
tableData: Array,
},";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}