// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ (\w*?): ((Number|String|Object|Array),?\n)").unwrap();
let string = "
props: {
book: Object,
progress: Object,
tableData: Array,
},";
let substitution = " $1: {\\n type: $3,\\n required: true\\n },\\n\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}