const regex = /^ (\w*?): ((Number|String|Object|Array),?\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ (\\w*?): ((Number|String|Object|Array),?\\n)', 'gm')
const str = `
props: {
book: Object,
progress: Object,
tableData: Array,
},`;
const subst = ` $1: {\n type: $3,\n required: true\n },\n\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);