$re = '/^ (\w*?): ((Number|String|Object|Array),?\n)/m';
$str = '
props: {
book: Object,
progress: Object,
tableData: Array,
},';
$subst = " $1: {\n type: $3,\n required: true\n },\n\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;