import re
regex = re.compile(r"^ (\w*?): ((Number|String|Object|Array),?\n)", flags=re.MULTILINE)
test_str = ("\n"
" props: {\n"
" book: Object,\n"
" progress: Object,\n"
" tableData: Array,\n"
" },")
subst = " $1: {\\n type: $3,\\n required: true\\n },\\n\\n"
result = regex.sub(subst, test_str)
if result:
print(result)